Blast Gates Rattling Problem

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by todd4390 posted 02-17-2015 09:00 PM 474 views 0 times favorited 3 replies Add to Favorites Watch
View todd4390's profile


130 posts in 886 days

02-17-2015 09:00 PM

I recently piped my dust collection (Jet 1100 Vortex) with pvc piping to various locations. Been usin it this way for about 2 weeks and just recently noticed that when I turn of the collector several of the closed blast gates make a pretty good rattling noise. I’m using 4” metal gates from Rockler and have checked all the thumb screws to make sure the gates are all secure. Anyone know what may be causing this?

3 replies so far

View Kazooman's profile


614 posts in 1371 days

#1 posted 02-17-2015 09:28 PM

Just a thought. Is there play for the gate blade and the slot it rides in? The thumb screw only anchors at one end so if there is much play the blade might flap in the breeze a bit as the vacuum decreases. Full suction would hold it firmly in place. Take one of your gates and see if you can wiggle the blade in the slot.

View English's profile


512 posts in 896 days

#2 posted 02-18-2015 09:01 PM

Which side of the gate has the thumb screw. If on the DC side of the gate it could be holding the gate off the seal ring allowing it to rattle.

-- John, Suffolk Virgina

View todd4390's profile


130 posts in 886 days

#3 posted 02-18-2015 09:21 PM

They are on the tool side. Think I fixed the problem. pushed a couple of the gates in tight to the back wall and secured the screw. That seems to have fixed it. I thought I had a clog in the system or something.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics