LumberJocks

Sketchup question

  • Advertise with us

« back to Designing Woodworking Projects forum

Forum topic by Mark posted 02-03-2015 04:56 AM 625 views 0 times favorited 9 replies Add to Favorites Watch
View Mark's profile

Mark

819 posts in 1435 days


02-03-2015 04:56 AM

I’m in the middle of drawing up a hutch and buffet in Sketchup. I started out making every thing a component. Some where down the line I exploded every thing to make modifications to the various pieces. Of coarse now I cant move anything as almost nothing is a component. I have to be able to move the pieces to attach measurements to them. Is there a solution to this or am I screwed?
Thanks in advance.

-- Mark


9 replies so far

View MT_Stringer's profile

MT_Stringer

2850 posts in 2691 days


#1 posted 02-03-2015 05:24 AM

It’s a little late, but I saw Jay make a copy of a component, pull it out in the open, make changes, then delete the copy. It works.

-- Handcrafted by Mike Henderson - Channelview, Texas

View jerryminer's profile

jerryminer

528 posts in 902 days


#2 posted 02-03-2015 05:34 AM

I think you have to go through and re-identify your parts as components.

What I would do is make a copy of the model (move/copy), select a part, move/copy to an empty spot and see how “clean” it is, then clean it up by erasing extra geometry and make it a component. Then move it back into the model. Do this with every part. Then you will be able to “hide” parts as you need, and erase the leftovers.

If you only need to pull measurements, you can do that in x-ray mode

View JAAune's profile

JAAune

1634 posts in 1777 days


#3 posted 02-03-2015 06:01 AM

Once you make a component, it should stay in the component menu even if there’s no instance of it in your drawing. Go to the menu bar at the top of the screen and select “Window → Components.” Look for the house icon and click that to view all the components that have been used in your model. You should be able to select them and place them back in your drawing.

-- See my work at http://remmertstudios.com and http://altaredesign.com

View lew's profile

lew

11335 posts in 3215 days


#4 posted 02-03-2015 04:14 PM



Once you make a component, it should stay in the component menu even if there s no instance of it in your drawing. Go to the menu bar at the top of the screen and select “Window → Components.” Look for the house icon and click that to view all the components that have been used in your model. You should be able to select them and place them back in your drawing.

- JAAune

Thanks! That solves some of the same problems I have had!

-- Lew- Time traveler. Purveyor of the Universe's finest custom rolling pins.

View TysonK's profile

TysonK

126 posts in 1263 days


#5 posted 02-04-2015 09:57 PM

Sorry if this is known, but just to be sure moving forward, why did you explode your components to make modifications rather than editing them?

Mike’s suggestion to pull your component away for easier editing is a great suggestion.

Another option: under the “View” menu is also an option for “Component Edit”, and this will let you hide other parts of the model while you are editing a component, also useful sometimes. If you find this option helpful, set it to a keyboard shortcut so you can toggle the rest of the model on and off quickly.

-- -- Tyson

View Mark's profile

Mark

819 posts in 1435 days


#6 posted 02-04-2015 10:51 PM

Thank you for the help gents. JA I followed your suggestion with great success.
Tyson Thanks for your suggestion. I’m still deep in learning mode(with enough knowledge to be dangerous). So the component editing thing was unknown.

-- Mark

View jmartel's profile

jmartel

6565 posts in 1610 days


#7 posted 02-04-2015 10:56 PM

All you have to do to edit components is to double click on it. It will shade everything else out, you edit it, and then double click somewhere not on the component and it will go back to the normal operating mode.

-- The quality of one's woodworking is directly related to the amount of flannel worn.

View Richard's profile

Richard

1898 posts in 2150 days


#8 posted 02-04-2015 11:02 PM


Once you make a component, it should stay in the component menu even if there s no instance of it in your drawing. Go to the menu bar at the top of the screen and select “Window → Components.” Look for the house icon and click that to view all the components that have been used in your model. You should be able to select them and place them back in your drawing.

- JAAune

Thanks! That solves some of the same problems I have had!

- lew


Helps me out also.

View Richard's profile

Richard

1898 posts in 2150 days


#9 posted 02-04-2015 11:03 PM



Thank you for the help gents. JA I followed your suggestion with great success.
Tyson Thanks for your suggestion. I m still deep in learning mode(with enough knowledge to be dangerous). So the component editing thing was unknown.

- Mark


Mark , you will always be in learning mode unless you are Dead. :)

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com