LumberJocks

problem with my Jet JJP-12HH

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by fisherdoug09 posted 09-25-2014 07:34 PM 666 views 0 times favorited 2 replies Add to Favorites Watch
View fisherdoug09's profile

fisherdoug09

121 posts in 2142 days


09-25-2014 07:34 PM

If anyone has one who is having a planer feed problem, I would like to chat with you. I have had my unit for just over a year and all of a sudden when planing the boards are not feeding through. The owners manual is not very helpful as how to fix the problem. A few suggestions in the trouble shooting pages, but does not go into detail how to fix the problem. Please let me know if you have had this issue. Thanks Doug


2 replies so far

View gfadvm's profile

gfadvm

14940 posts in 2158 days


#1 posted 09-26-2014 01:00 AM

I don’t have that planer, but cleaning the bed and feed rollers on my Ridgid 13” and my Woodmaster 18” seemed to fix my feeding issues.

-- " I'll try to be nicer, if you'll try to be smarter" gfadvm

View runswithscissors's profile

runswithscissors

2192 posts in 1493 days


#2 posted 09-26-2014 07:01 AM

I occasionally have that problem. Every time, it turns out I forgot to use the lever on the left side to put the feed rollers in “gear” (they’re actually belt driven). Happened to me just the other day. Of course, it happens when going from jointing to planing.

-- I admit to being an adrenaline junky; fortunately, I'm very easily frightened

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com