GO555 running rough.

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Jim Finn posted 06-05-2014 03:19 PM 826 views 0 times favorited 2 replies Add to Favorites Watch
View Jim Finn's profile

Jim Finn

2390 posts in 2343 days

06-05-2014 03:19 PM

Topic tags/keywords: bandsaw

I have had my GO555 for over five years and it started thumping as it ran. It would come and go. Last week I tore into it and found a lot of play in the lower wheel. I took it apart and found the two bearings to be just fine but the wheel shaft appeared to be worn a bit under one of the bearings. I had to use a gear puller with a lot of force to get the shaft out of the wheel. Grizzly sent me a new shaft in short order at a cost of $9.50 + $8.50 shipping. I put it together today and it solved the problem. Runs as smooth as it did when it was new. The new wheel shaft just took a little tapping and some WD-40 and it when right on. Good to have my saw back up and running. I use this saw mostly for re-sawing.

-- "You may have your PHD but I have my GED and my DD 214"

2 replies so far

View NikkiLaRue's profile


296 posts in 903 days

#1 posted 06-05-2014 03:22 PM

Glad you were able get it back up and running!

View Druid's profile


1231 posts in 2216 days

#2 posted 06-06-2014 05:34 AM

So, do you now refer to your saw as “Thumper”?
Glad to hear that the problem has been solved to your satisfaction.

-- John, British Columbia, Canada

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics