LumberJocks

Lathe Help

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Gixxerjoe04 posted 05-19-2014 09:13 PM 587 views 0 times favorited 4 replies Add to Favorites Watch
View Gixxerjoe04's profile

Gixxerjoe04

835 posts in 1043 days


05-19-2014 09:13 PM

So i picked up a lathe yesterday, the pulley’s needed to be replaced and came with it so figured no problem. Well i got the set changed on the motor and now i can’t get one piece off the other part. I broke quite a bit off the pulley trying to break it free only to realize it was being held on by a little clamp behind the black speed adjustment thing. It’s probably next to impossible to get behind it with out taking the whole thing off but i don’t know how or if it’s even possible to do. Tried getting some small allen wrenches behind it to pry it off but it hasn’t worked. Anyone have any insight on this problem?


4 replies so far

View Gixxerjoe04's profile

Gixxerjoe04

835 posts in 1043 days


#1 posted 05-19-2014 11:36 PM

This thing is about to make me go crazy, tried calling harbor freight tech support and of course they closed 5 minutes before i called.

View DIYaholic's profile

DIYaholic

19180 posts in 2141 days


#2 posted 05-20-2014 01:04 AM

You need “snap ring pliers”.
http://www.amazon.com/s/?ie=UTF8&keywords=snap-ring+pliers&tag=mh0b-20&index=aps&hvadid=3527175889&ref=pd_sl_609nlxskea_ee

-- Randy-- I may not be good...but I am slow! If good things come to those who wait.... Why is procrastination a bad thing?

View Gixxerjoe04's profile

Gixxerjoe04

835 posts in 1043 days


#3 posted 05-20-2014 01:22 AM

Yea feel like an idiot, i went and bought a pair before knowing there was a hidden one and at the time didn’t know about the 90 degree ones they sell. Wasted $15 on the pair when i needed the other, hopefully it wont be a pain to get it back on and the variable speed screw back in, in the right spot. A night of wasted time and frustration.

View Gixxerjoe04's profile

Gixxerjoe04

835 posts in 1043 days


#4 posted 05-20-2014 10:54 PM

Got the snap ring out and was excited to finally get it fixed. Well the dang thing is still stuck on there like a rock. Tried a propane torch, wd40, called harbor freight making sure there wasn’t something invisible on it I’m missing. This thing is about to get a sledge hammer. Don’t know what else to do.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com