LumberJocks

Grizzly 1028z or 1029 Dust Collector issue/problem

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Skippy906 posted 277 days ago 445 views 0 times favorited 2 replies Add to Favorites Watch
View Skippy906's profile

Skippy906

100 posts in 584 days


277 days ago

Topic tags/keywords: dust collection grizzly1028 1029

I have a this dust collector and it recently had a slight problem. The 5/16 bolt that holds the impeller on to the shaft, came off. It started making, something like a grinding noise when stopping, and after looking into the problem, I found the bolt missing from the shaft.

I am not sure if there was Loctite on the bolt or not, but I am guessing it didn’t have it. So if anyone out the on the LB world, take about 15 minutes and look at this and make sure yours is secure.

-- Making progress


2 replies so far

View knotscott's profile

knotscott

5368 posts in 1973 days


#1 posted 277 days ago

Did it run for several years before you had this issue? My G1029 has been fine for 10+ years so far, but that’ll be the first thing I check if I hear any funny noises from it. Thanks for the alert.

-- Happiness is like wetting your pants...everyone can see it, but only you can feel the warmth....

View Skippy906's profile

Skippy906

100 posts in 584 days


#2 posted 277 days ago

I have had this dust collector since the fall of 2003. This issue just happened this past year. Here is a pic of the collector and a close up of the bolt that fell out.

-- Making progress

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase