LumberJocks

powermatic 66

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by scott73 posted 08-12-2013 07:03 AM 668 views 0 times favorited 1 reply Add to Favorites Watch
View scott73's profile

scott73

7 posts in 1444 days


08-12-2013 07:03 AM

Having some issues raising the blade. It lowers fairly well. I stuck my head inside and brushed off as much crud as I could. As I watched the shaft and raised the mechanism, it turns quite tough and there appears to be a black collar (see where toothbrush is touching). The black collars kind of also rotates, stops, and continues to rotate with crank. When I lower the blade, it lowers away at the same rate, no slipping. Any help or ideas? I’d like to not take the top off and go any further, although it has been a decade.

Scott

-- Scott


1 reply so far

View scott73's profile

scott73

7 posts in 1444 days


#1 posted 08-12-2013 01:38 PM

Update: I did some cleaning the best I could without dismantling the whole top and rails; I also lubricated the everything I cold get to. I read in the manual that it says the worm gear must be centered and if it is not, to loosen the set screw and make it centered. There is a set screw on the worm, and two on the collar behind the crank handle. If I push up and forward on the trunnion, I can make it move forward maybe an 1/8th of an inch. The handle and shaft assembly will move forwards and back.

-- Scott

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com