LumberJocks

Planer tripping circuit - FIXED

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Sandra posted 525 days ago 858 views 0 times favorited 23 replies Add to Favorites Watch
View Sandra's profile

Sandra

4127 posts in 671 days


525 days ago

Topic tags/keywords: planer ridgid question

Howdy,

I tried to start my Ridgid 13” thickness planer two days ago and it immediately tripped the circuit. It was at the cold end of my shop, so I wasn’t too concerned about it.

I rolled it closer to the heater and cranked up the heat overnight. Next day, tried it again, letting it run for a second or two at a time and then shutting it off again. I did this numerous times, but each time it runs past about 5 seconds, it trips again.

Today is day three. The shop has been above 10 deg celcius/50F for two days, and still it won’t run past 5 seconds.

No doubt I need more power to my shop, but I was running it no problem last summer. The shop rarely gets close to freezing , and I keep the heat running whenever I’m going to be out there.

Any suggestions? Getting frustrated.

-- No, I don't want to buy the pink hammer.


23 replies so far

View Monte Pittman's profile

Monte Pittman

13212 posts in 934 days


#1 posted 525 days ago

You said you have heat on when you’re out there. If you’re running a space heater it could be overloading circuit.

-- Mother Nature created it, I just assemble it. - It's not ability that we often lack, but the patience to use our ability

View PurpLev's profile

PurpLev

8476 posts in 2245 days


#2 posted 525 days ago

what kind of heat are you running in there? electric? if so, that is what is tripping your power – the heater+power tool (+lights + etc?)

-- ㊍ When in doubt - There is no doubt - Go the safer route.

View MrRon's profile

MrRon

2716 posts in 1839 days


#3 posted 525 days ago

Either there is a big power demand resulting in lower than normal voltage or you are using a too small extension cord. Is the space heater on the same circuit as the planer and are you running the heater at the same time?

View Clint Searl's profile

Clint Searl

1380 posts in 957 days


#4 posted 525 days ago

You probably have a 15 amp breaker on a 14 ga circuit, and the planer is pulling more amps than the circuit can handle. If there’s room in the panel, you can add a 12 ga line on a 20 amp breaker.

Make sure the planer is OK by returning it to HD and getting a replacement before upgrading the wiring.

-- Clint Searl.............We deserve what we tolerate

View unisaw2's profile

unisaw2

179 posts in 1631 days


#5 posted 525 days ago

Ditto from above. Start by turning everything off that is on that circuit and see if the planer will run. If this is on a 15 amp circuit it needs to be the ONLY thing.

-- JJ

View JoeinGa's profile

JoeinGa

3088 posts in 603 days


#6 posted 525 days ago

If you are using an extension cord, first thing is take the extension off and try plugging the planer directly into the wall. And if you ARE using an ext cord, it needs to 10 gauge and no more than 40 foot long.

-- Perform A Random Act Of Kindness Today ... Pay It Forward

View Jamie Speirs's profile

Jamie Speirs

4085 posts in 1452 days


#7 posted 525 days ago

Sandra with the machine unplugged
turn it a few times by hand then try it.

Jamie

edit; sorry I just reread it and it has turned

-- Who is the happiest of men? He who values the merits of others, and in their pleasure takes joy, even as though 'twere his own. --Johann Wolfgang von Goethe

View nwbusa's profile

nwbusa

1016 posts in 882 days


#8 posted 525 days ago

And if you ARE using an ext cord, it needs to 10 gauge and no more than 40 foot long.

10 gauge seems a little excessive. 12 gauge should be plenty adequate.

-- John, BC, Canada

View Sandra's profile

Sandra

4127 posts in 671 days


#9 posted 525 days ago

Hmmm – I had the heater off, but maybe it’s still pulling power. I’ll give it a try in the morning.

Thanks. I’ll let you know how I make out.

-- No, I don't want to buy the pink hammer.

View DocSavage45's profile (online now)

DocSavage45

4732 posts in 1439 days


#10 posted 525 days ago

Sandra,

all good advice.

What is the amperage of your planer? My table saw requires one seperate circuit.

1500 watts of powerfor electric heaters

P=E/I and reversed. light circuits in most instances are 15 amps. walls run at about 20 amps new wiring?

Has this happened before? May be bearing problem in jointer? Do you have ground faults installed?

-- Cau Haus Designs, Thomas J. Tieffenbacher

View crmitchell's profile

crmitchell

35 posts in 555 days


#11 posted 525 days ago

I looked on the HD website and the planer model currently listed is a 15 amp machine. If you have ordinary wiring, it is likely a 15 amp circuit – the planer should trip the breaker at start-up. If not, the breaker is defective.

If a 20 amp circuit (look on the breaker), and it worked before, the breaker could be bad – they do go bad. Fortunately, they are cheap and easy to replace.

View nwbusa's profile

nwbusa

1016 posts in 882 days


#12 posted 525 days ago

I run this same planer on a 15A circuit and it doesn’t trip it at startup or any other time.

-- John, BC, Canada

View Sandra's profile

Sandra

4127 posts in 671 days


#13 posted 525 days ago

Okay, so without getting too sappy, I just want you to all know how much I appreciate the help. There is no way on G’s green earth I’d get any projects done without the assistance here.

I plugged the planer directly into the outlet with nothing else on. Same thing as before – circuit tripped.

Then Jamie’s comment came to mind. It was turning wasn’t it?? So I unplugged it and tried to turn the blades by hand. No go. The motor was running before, but nothing in fact was moving, hence the circuit problem. A sip of coffee and I noticed a little red button near the blades. Gave that a push and lo and behold I could turn the blades. Plugged it back in and voila! But when it stopped, it seemed to come to a sudden stop and the red button was back out again.

A few more sips of coffee, a head tilt, a chin scratch and then the thought crossed my mind that it was pretty dangerous for the blades to be exposed like that. And then the lightbulb came on. DOUBLE DUH! The last time I used the planer, I took off the dust hood. The dust hood apparently keeps the red button depressed so that the planer runs. Evidently it’s protection for morons like me!

So suffice it to say, I put the dust hood back on and it works great.

Without this site, I probably would have called an electrician, or tried to get the planer serviced or who knows what else.

Hats off to you, have a great day!
Sandra

-- No, I don't want to buy the pink hammer.

View DIYaholic's profile

DIYaholic

12860 posts in 1271 days


#14 posted 525 days ago

Glad the issue has been resolved.

We have ALL had many a forehead slapping, “Duh” moment!!! Just be sure not to hit yourself hard enough to do any permanent brain damage (too late for me)!!!

-- Randy-- I may not be good...but I am slow! If good things come to those who wait.... Why is procratination a bad thing?

View Bogeyguy's profile

Bogeyguy

457 posts in 664 days


#15 posted 525 days ago

What’s wrong with dain bramage??

-- Art, Pittsburgh.

showing 1 through 15 of 23 replies

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase