LumberJocks

Delta AP300 dust collector lost suction power!! please help

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by nkfly posted 575 days ago 1013 views 0 times favorited 2 replies Add to Favorites Watch
View nkfly's profile

nkfly

1 post in 576 days


575 days ago

actually, I think I got screwed, bought this dust collector on Craigslist,

I didnt realize how weak the suction power was until I put it right next to my round saw,

the weird part is when I took off the dust bag, the suction is very strong..and it works fine,

but I can not leave it open like that. the opening blow out dust to everywhere.. unless I have

a long hose connecting to outside.

any idea ??


2 replies so far

View Fred Hargis's profile

Fred Hargis

1730 posts in 1126 days


#1 posted 575 days ago

Sounds like that bag may be clogged. Hang it opening down and beat the snot out of it with a 4’ long 1” dowel or suitable substitute. Then turn it inside out and vacuum the surface and try it. If you air flow returns be aware I think that may have come with 30 micron, which trap almost none of the finest dust particles. Instead it will just re circulate them into your shop.

-- Our village hasn't lost it's idiot, we sent 'em to Washington.

View jap's profile

jap

1226 posts in 687 days


#2 posted 575 days ago

probably needs a new bag

-- Joel

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase