LumberJocks

Rockwell/Delta 1970 Scroll Saw: How do I replace the blade?

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Galadriel posted 621 days ago 1222 views 0 times favorited 0 replies Add to Favorites Watch
View Galadriel's profile

Galadriel

7 posts in 663 days


621 days ago

Topic tags/keywords: scrollsaw rockwell delta blades

Hey folks! I posted earlier about a bunch of saws I got at the same time. I am pretty happy about your advices on the table saw, though I had to wait for parts to arrive before I could try it. I got almost everything in the mail and assembled, but then I had to go out of town.

While I’m out of town, I was hoping maybe you folks could help me with another of the saws I got that day. It’s a Rockwell/Delta scroll saw that the guy didn’t know much about. It is, by the way, pink, in case you can see the body of the saw in the photos below. The seller said his dad was trying to paint it red but made a mistake with the paint mix. Ah, well.

It didn’t have a belt but the motor worked fine, the saw turned easily, the table moved easily and locked firmly, and it had a blade in it so I assumed I could work out how to get the blade in and out either by playing with it, or by finding a manual online.

Boy, was I wrong. The serial number indicates it’s from 1970, and I found a manual. But the blade insert doesn’t look the same in the manual as the one on my saw. Okay, there are no holes at the top of the blade, so I assume it is pinless. The clutch at the top is easy; it’s the bottom that’s a problem. Let me add I sprayed everything liberally with tri-flow to try to loosen up anything that might be stuck, to make it all move as easily as possible.

So the bottom has a set screw, but loosening the set screw only allows me to rotate the (excuse me for not knowing the term) bottom piston—the part that goes up and down in response to turning the wheel—so that the blade can point to the side or the front.

I couldn’t find anything else on it that would let the blade go. I thought maybe it just slipped in and out, so I tugged on it a little…and the old, rusty blade that was in it…broke. And left the very bottom of the blade stuck inside.

Here’s what the piston looks like at the top:
https://dl.dropbox.com/u/34814534/2012-10-11%2008.34.04.jpg
https://dl.dropbox.com/u/34814534/2012-10-11%2008.34.19.jpg
https://dl.dropbox.com/u/34814534/2012-10-11%2008.34.35.jpg
https://dl.dropbox.com/u/34814534/2012-10-11%2008.34.48.jpg
https://dl.dropbox.com/u/34814534/2012-10-11%2008.34.52.jpg

I am so sorry for the quality of the photos. I think you can see the set screw There is a hole that goes all the way through from one side to the other; I can’t tell if it’s threaded inside and should maybe have some kind of set screw in it. Or if there’s a part missing that should go through the hole. Maybe it’s a pin blade after all, and that’s supposed to hold the blade on?

I tried to use an awl to dig the bit of broken blade out, but I can’t get the blade clamp “lips” to move at all. Are they fused from rust? Or do I need to do some thing to release them?

Does anyone recognize this attachment? Can you tell me what I need to do to get the last bit of the old blade out, and to insert blades that I can use?

Thank you!


0 replies so far

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase