LumberJocks

Table saw motor - spins & sticks

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by dave posted 647 days ago 854 views 0 times favorited 9 replies Add to Favorites Watch
View dave's profile

dave

16 posts in 1154 days


647 days ago

I have a Rigid 2400 table saw that I bought second hand. It worked well up until recently when I noticed the blade started to loosen and spin freely after making a cut. I tightened it up and cut a small piece of scrap. After turning it off again, the blade kept spinning and the arbor was loose. I put a small dab of loc-tite on on and after another cut, the blade spun after being turned off but the arbor nut was still on tight.

I unplugged it and spun the blade. It spun freely for 3/4 of a turn and then got snug and more force was needed to get it to complete a revolution. I pulled the insert off again and removed the blade. Grabbing the arbor, it spins part way and seems to bind or tighten.

Has anyone experienced this issue before? I hope to get the motor off this weekend and am trying to decide on whether to buy a new one and do a swap all at once or bring it in to a rebuild shop for repair.

I think it is likely the arbor assembly, so I’m hoping someone might confirm this via experience…..


9 replies so far

View DIYaholic's profile (online now)

DIYaholic

11246 posts in 1177 days


#1 posted 646 days ago

I am of no help, but I thought I wood bump your post. Hope that helps.

-- Randy-- I may not be good...but I am slow! If good things come to those who wait.... Why is procratination a bad thing?

View Sawkerf's profile

Sawkerf

1730 posts in 1570 days


#2 posted 646 days ago

Do you have a large “washer” between the blade and arbor nut? If not, should you? Is your arbor nut directional (i.e. needs to go on the arbor a certain way?

These things might cause the arbor nut to not tighten enough.

-- Adversity doesn't build character...................it reveals it.

View whitewulf's profile

whitewulf

423 posts in 1439 days


#3 posted 646 days ago

What happens if you hold the blade & turn it on? Seriously, clamp scrap board to table, raise the blade to touch and switch quickly on/off. OR MAYBE BETTER TO DISASSEMBLE SAW. Not familiar with Rigid drive, But I had similar problem with an old Delta saw. the motor was not direct drive. Used small cog belt to drive the blade with short arbor, all the teeth stripped off of the belt allowing the blade to spin until started to cut. Allthis was in motor housing! New belt, all OK now.

-- "ButI'mMuchBetterNow"

View dave's profile

dave

16 posts in 1154 days


#4 posted 646 days ago

Sawkerf – there is an inner and outer blade washer that are both installed. It’s not so much the arbor nut but the arbor itself that seems broken. I get this issue even with the blade removed.

Whitewolf – it is direct drive. If I leave the blade on, it will spin and cut for a bit before the blade loosens up and the arbor just spins. I removed the blade and washers, if I grab the arbor and spin it, it rotates easily about 3/4 of a rotation. At that point, it seems to bind up and I have to force it the rest of the rotation where it loosens up again and spins easily.

It seems as though it’s a gear/bearing related issue but I don’t know enough about the arbor assembly that attaches to the motor. I was hoping someone has dealt with this…...

View boneskennedy's profile

boneskennedy

27 posts in 655 days


#5 posted 646 days ago

sounds like one of the magnets in the motor is lose to me, thats just my 2cents tho (its a easy fix)
Jon

View ajosephg's profile

ajosephg

1826 posts in 2063 days


#6 posted 646 days ago

I think Whitewolf has nailed it. The belt is inside the motor/arbor housing and probably the cogs are stripped off on all or part of it.

-- Joe

View dave's profile

dave

16 posts in 1154 days


#7 posted 646 days ago

Thanks guys…I will dig into it then before bringing to a repair shop. I got a good deal on it ($80) so I don’t want to spend a bunch fixing it up. The guy was a contractor so it did take some hits but for the price, I couldn’t pass it up. It was too big for him and after his work truck was hit by a car, he bought another one. It worked good for me for the past year but just recently started with the troubles.

View J's profile

J

46 posts in 649 days


#8 posted 646 days ago

I have one of those saws—there are some screws that hold the arbor assembly tight to the motor, if those screws have been removed, stripped or fallen out that would account for the problems you are having.

here is a schematic, http://www.ereplacementparts.com/ridgid-ts2400ls-table-saw-parts-c-7929_8171_8173.html?page=3

View whitewulf's profile

whitewulf

423 posts in 1439 days


#9 posted 639 days ago

Any fix yet? Curious as to the problem

-- "ButI'mMuchBetterNow"

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase