LumberJocks

band saw fence

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by gmussell posted 01-25-2012 09:33 PM 695 views 0 times favorited 2 replies Add to Favorites Watch
View gmussell's profile

gmussell

17 posts in 1810 days


01-25-2012 09:33 PM

I was trying to get my new used Jet 14” band saw going, had to by a new table bracket and lower blade support bearing. When I went to try the fence, I noticed that the fence would not lock. There is a metal tab that the locking mechinizm (sp) pushes up against the fence rails. I thought it might be bent, I bent it back some, I did not want to get carried away and break it. Was I doing the right thing? Has any one else had this trouble.

Thanks

George


2 replies so far

View gmussell's profile

gmussell

17 posts in 1810 days


#1 posted 01-26-2012 10:09 PM

I found the problem, I got ahold of Jet customer service. The little metal tab is supposed to have a plastic pad on it, mine did not. $2.75 and $5 shipping(ouch) and I should be good to go.

thanks

George

View NBeener's profile

NBeener

4808 posts in 2637 days


#2 posted 01-26-2012 10:26 PM

Glad we could help ;-)

-- -- Neil

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com