Planer problem

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by mrbuck50 posted 12-25-2011 11:52 AM 732 views 0 times favorited 2 replies Add to Favorites Watch
View mrbuck50's profile


3 posts in 1763 days

12-25-2011 11:52 AM

I have a Hitachi 13” planer. I am having difficulty getting some species to go through…...the rollers won’t grab the material. It seemas that pine does fine, but hardwoods (oak, purpleheart, hard maple so far) dont want to feed properly. I have cleaned my rollers several times with brake cleaner and it makes no difference. I misted some of the hard maple with water and it helped. Any ideas?
Thanks in advance…...........

2 replies so far

View shopdog's profile


575 posts in 2903 days

#1 posted 12-25-2011 12:10 PM

When that happens with my Makita planer, I wax (bowling alley wax) the table, or spray it with topcote.

-- Steve--

View Loren's profile


8158 posts in 3066 days

#2 posted 12-25-2011 07:45 PM

Springs force the feed rollers down on such planers. The springs
are not as robust as the springs found on some stationary planer
models with rubber coated feed rollers. You can wax and polish the
bed and keep the rollers clean, but ultimately at times you’ll have to
stand there and help the planer but pushing the wood in and
pulling it out.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics