LumberJocks

Sawstop died, I may be screwed for christmas gifts...

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by omextreme posted 12-14-2011 07:59 AM 2249 views 0 times favorited 27 replies Add to Favorites Watch
View omextreme's profile

omextreme

49 posts in 1094 days


12-14-2011 07:59 AM

Long story short, my sawstop is dead and Christmas is less then 2 weeks away. I delayed the start of all the gifts I have promised to friends and family for Christmas so I could renovate my shop. That being said my trusty JET found a new home a few weekends back and now I am stuck without a tablesaw.

I am not sure what is wrong other then no lights and no power. Just finished crosscutting a piece of maple and went to restart the saw… Dead. Tried all the steps in the manual still nada.

We will see what the mfg can do in the morning, I may have to resort to hard wiring the motor and bypassing all the cool features to make Christmas happen…

Just venting…..


27 replies so far

View Loren's profile (online now)

Loren

7808 posts in 2365 days


#1 posted 12-14-2011 08:15 AM

Probably the switch. Magnetic switches have a lot of parts in them
and can get out of whack. Take it apart and check for dust, loose
connections and so on.

I have a misbehaving switch on my planer, it trips off for no reason
once in awhile. One of these days it’s really going to just not start
and I’ll have to roll up my sleeves and open it up for a look.

-- http://lawoodworking.com

View Rick  Dennington's profile

Rick Dennington

3551 posts in 1912 days


#2 posted 12-14-2011 08:16 AM

Did you check to make sure you didn’t throw a breaker…..? Do you have your saw on a seperate breaker?

-- " I started with nothing, and I've still got most of it left".......

View omextreme's profile

omextreme

49 posts in 1094 days


#3 posted 12-14-2011 08:22 AM

Thanks for the ideas, power is good, and I checked the switch with the multimeter. All good other then the part about the whole thing not working.

View agallant's profile

agallant

436 posts in 1604 days


#4 posted 12-14-2011 08:06 PM

Things to check.

1. turn the saw off (the actual power switch) and push in the red breaker on the side.
2. Mine died and it turned out that I pulled out the cables on the inside of the black box that has the power on/off and key switches in it. I had to take it apart. They are not soldered on just quick connectors.
3. There will be an old school serial DB-9 cable that runs from the box to the break device, if this is disconnected the saw won’t show as on.

I think you have pulled out one of the quick connect cables on the inside of the black box.

Good luck, let me know how it goes.

-AG

View Betsy's profile

Betsy

2914 posts in 2613 days


#5 posted 12-14-2011 08:25 PM

One other thing to check – is your key in or out of the key slot. Check that it’s in the on position.

Did you try the old – just unplug it, let it sit and then plug it back in trick?

-- Like a bad penny, I keep coming back!

View klassenl's profile

klassenl

116 posts in 1377 days


#6 posted 12-15-2011 05:17 AM

Betsy wrote, “Did you try the old – just unplug it, let it sit and then plug it back in trick?”

My dad (a plumber) called me (an electrician) for some advice one day on a Geothermal furnace. I asked if he turned the power off and then on again….............problem solved.

-- When questioned about using glue on a garbage bin I responded, "Wood working is about good technique and lots of glue........I have the glue part down."

View omextreme's profile

omextreme

49 posts in 1094 days


#7 posted 12-15-2011 06:52 AM

Thanks for all the ideas. Spoke with the sawstop guys and we diagnosed a bad 6v power supply board. They will be overnighting one out so hopefully we will be cutting by the weekend.

View IrreverentJack's profile

IrreverentJack

724 posts in 1561 days


#8 posted 12-15-2011 02:36 PM

Adam, Did SawStop charge you anything? -Jack

View HorizontalMike's profile

HorizontalMike

6960 posts in 1631 days


#9 posted 12-15-2011 05:00 PM

I think Loren is on the right track, but look deeper if the SS diagnosis is incorrect…

On my TS (different manufacturer) it is the STOP button that sticks in the kill position (probably dust, but haven’t checked yet). The TS won’t start UNTIL I pull the red Stop button to the outer position. Once the Stop button is in the extended position all is OK with the world.
My 2-cents…

-- HorizontalMike -- "Woodpeckers understand..."

View omextreme's profile

omextreme

49 posts in 1094 days


#10 posted 12-15-2011 05:17 PM

Sawstop guys seemed to be leaning towards ground shipping stating it would “only” take 5 days to reach me. I protested slightly that with christmas approaching 5 days would be an issue. A quick question the the supervisor and they offered to overnight the part.

No charge!

View Brandon's profile

Brandon

4145 posts in 1669 days


#11 posted 12-15-2011 05:19 PM

Excellent to hear about their good customer service, even though you weren’t the original purchaser of the saw. This bodes well for SawStop.

-- "hold fast to that which is good"

View Bertha's profile

Bertha

12951 posts in 1411 days


#12 posted 12-15-2011 06:02 PM

^I agree, Brandon. Nice to see someone standing up and doing the right thing. Like Mike and Loren, I’ve had sticky switches before. The magnetic switch on my bandsaw has always been a bit “smooshy”, if you know what I mean. How did SS diagnose a 6V board over the phone? Did they make you probe the board with your multimeter or just guess?

-- My dad and I built a 65 chev pick up.I killed trannys in that thing for some reason-Hog

View basset's profile

basset

12 posts in 2118 days


#13 posted 12-15-2011 06:08 PM

Another good reason to buy a SawStop. Their customer service is excellent!!!

-- Don aka Basset Hound, www.woebgonbassets.com

View omextreme's profile

omextreme

49 posts in 1094 days


#14 posted 12-15-2011 06:10 PM

The diagnosis was made by jumping 2 of the pins in the control cable port on the main board. According to sawstop this should have made one of the led’s light up. If we had lights then power supply would have been ok, no lights = bad power supply. (I confirmed with my multimeter after the call) the motor could be hardwired if need but with my luck I’d lop off a digit with a bypassed safety… (not that I did before with any of my other tools) So ill sit by the front door looking outside for the ups guy for the next little while.

View Bertha's profile

Bertha

12951 posts in 1411 days


#15 posted 12-15-2011 06:12 PM

Clever solution! You KNOW that if you ever have an injury, it’ll be when you’ve bypassed a safety mechanism temporarily, lol. Good luck getting her back up and running!

-- My dad and I built a 65 chev pick up.I killed trannys in that thing for some reason-Hog

showing 1 through 15 of 27 replies

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase