LumberJocks

2 hp motor for Laguna MDC0560-0145 cyclone dust collector

  • Advertise with us

« back to Woodworking Trade & Swap forum

Forum topic by mnguy posted 10-26-2018 01:14 AM 387 views 0 times favorited 6 replies Add to Favorites Watch
View mnguy's profile

mnguy

199 posts in 3571 days


10-26-2018 01:14 AM

Topic tags/keywords: motor laguna dust collector 2 hp

This motor has less than 1 hour of run time on it – it is virtually new. Another wood worker in the MINNEAPOLIS area had issues with this unit running that turned out to be starting capacitors, not the motor. In the course of diagnosing the problem, Laguna sent him 2 new motors. I bought the unit from him, and inherited the motors. I have one motor left and will sell it for $100 plus shipping (probably less than $50 for most of you in the US).


6 replies so far

View Alex Lane's profile

Alex Lane

539 posts in 4063 days


#1 posted 10-28-2018 12:07 AM

I’m assuming the capacitor problem is fixed? :)

-- Lane Custom Guitars and Basses

View mnguy's profile

mnguy

199 posts in 3571 days


#2 posted 10-31-2018 04:13 PM

Alex – yes, the capacitor problem was fixed. I actually bought the Laguna DC from another local wood worker, and Laguna shipped him two new motors and a pile of capacitors in the process of trouble shooting the issue. I have extra capacitors, too.

View Alex Lane's profile

Alex Lane

539 posts in 4063 days


#3 posted 11-03-2018 11:14 PM

Face mount or base mount? Or both?

-- Lane Custom Guitars and Basses

View Mike_D_S's profile

Mike_D_S

491 posts in 2388 days


#4 posted 11-04-2018 01:43 PM

Alex,

MNGuy will probably reply, but based on the one used Laguna collector I looked at locally, I believe the motor is face mount only.

Mike

-- No honey, that's not new, I've had that forever......

View mnguy's profile

mnguy

199 posts in 3571 days


#5 posted 11-05-2018 08:41 PM

Alex,

MikeD S is correct – the Laguna motor is face mount only. I can double check and see if there are threaded bosses or areas that could be drilled and tapped, but I suspect there are none. I can PM you with a couple photos and confirmation.

Chris

View mnguy's profile

mnguy

199 posts in 3571 days


#6 posted 11-09-2018 01:53 PM

Confirmed – there is no area on the motor housing to tap or otherwise bolt anything to the motor base. To base mount it, you’d have to make a mount that bolted to the face mounting plate.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com