LumberJocks

Bosch 1617 Router not starting

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Brian024 posted 04-07-2011 01:43 AM 2291 views 0 times favorited 12 replies Add to Favorites Watch
View Brian024's profile

Brian024

358 posts in 2057 days


04-07-2011 01:43 AM

Topic tags/keywords: router

Has anyone had any issues with theirs not starting? I was going to do some routing and installed the bit and everything and put it back in the table and it won’t start. Before I get into more in depth trouble shooting I wanted to see if anyone else has had problems with it. I’ve had it for about 2 years so far and it gets fairly light use I guess you could say, I estimating I’ve put 40 or 50 hours on it. I’m not in dire need of it since I have the Ridgid but would like to get it up and running soon. A few things to make note of; the router was plugged into a working outlet and when I plug it in and turn on the switch, there is no humming sound (I was checking to see if the motor might be locked up).


12 replies so far

View wolfman's profile

wolfman

2 posts in 1332 days


#1 posted 04-07-2011 01:52 AM

I seem to recall that there were some issues with the switch on those, but I thought it was on earlier models. I believe the earlier switches were not sealed properly and failed. Suggest checking with Bosch. Sorry about the problem. I have that model as well. No problems so far, though.

View cabs4less's profile

cabs4less

235 posts in 1419 days


#2 posted 04-07-2011 02:28 AM

Yeah the switcth is not dust sealed. I had the earlier model and when I called bosch they said thier warrenty didnt cover the switch cause it was abused because i let dust get in it i took it back to lowes and I HAVE NEVER BOUGHT ANOTHER BOSCH TOOL AND WILL NOT.

-- As Best I Can

View mcase's profile

mcase

438 posts in 1786 days


#3 posted 04-07-2011 03:34 AM

I assume its out of warranty. What do they want for new switch?

View mwoberr's profile

mwoberr

5 posts in 1454 days


#4 posted 04-07-2011 04:42 PM

I have that issue sometimes on my 1617. I shop-vac out the switch then hit it with compressed air to clean the switch…seems to work. Now I have the 1617 mounted in my router table and hooked up to a rockler saftey switch so I don’t use the switch on the router any more….problem solved.

View Brian024's profile

Brian024

358 posts in 2057 days


#5 posted 04-07-2011 08:17 PM

The switch would be the problem, even blew the dust out of it. It isn’t under warranty, so I’m going to buy a new switch. The experience that I have had with Bosch it seems strange how they haven’t solved the switch problems yet, not enough that it will make me stop buying their tools though. Funny how the switch is only $4.00 and the shipping is $8.00 and that is for the slow shipping, next day shipping was in the range of $40.00! I might have to consider that mwoberr, since it just gets used in the router table.

View Brian024's profile

Brian024

358 posts in 2057 days


#6 posted 04-15-2011 04:12 PM

Well, so much for the switch being the problem. The old one was bad but after I put the new one in, it still doesn’t start.

View Lee Barker's profile

Lee Barker

2163 posts in 1508 days


#7 posted 04-15-2011 06:31 PM

Long shot: I’ve had a wood chip get between one brush and the armature. Found it, removed it, motor started.

Kindly,

Lee

-- "...in his brain, which is as dry as the remainder biscuit after a voyage, he hath strange places cramm'd with observation, the which he vents in mangled forms." --Shakespeare, "As You Like It"

View devann's profile

devann

1735 posts in 1350 days


#8 posted 04-15-2011 06:51 PM

I was going to mention check the brushes. It’s next on the list after a switch if the motor won’t start or begains to sound different. You could have a broken wire at one of the brushes. I have an old Ryobi beam saw that I thought died, turned out I needed to remove a brush and stretch the spring back out some. It works now.

-- Darrell, making more sawdust than I know what to do with

View Brian024's profile

Brian024

358 posts in 2057 days


#9 posted 04-20-2011 07:10 PM

I just happened to be the brushes, it wasn’t the brushes themselves but one of them wasn’t touching the commutator of the armature. It may have gotten pushed back when I changed the switch, but it is alive again.

View JasonIndy's profile

JasonIndy

186 posts in 2092 days


#10 posted 04-21-2011 05:17 AM

Good to hear. I’ve got the same router and (knock on wood) haven’t had any issues yet. I’m relieved it wasn’t anything major.

View MC's profile

MC

65 posts in 1004 days


#11 posted 02-15-2012 03:01 AM

I bought this router in July and only have a couple of hours on it. Went to work on project this weekend and nothing when I turned it on. It is still under warranty, interested to see if it is the switch or not.

View AdamD's profile

AdamD

1 post in 449 days


#12 posted 06-30-2013 06:39 PM

Just wanted to add…it’s 2013, I bought the same router in Dec 2012, and my switch just had to be removed and cleaned. So they still haven’t fixed this. Works, but a real PITA when you have ONE piece of trim left to profile and it means 2 hrs and a trip to Lowe’s. Need #15 torx to get the case off.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase