LumberJocks

Powermatic 95 alignment issue?

  • Advertise with us

« back to Scrollsawing forum

Forum topic by snidd111 posted 11-01-2017 10:10 AM 304 views 0 times favorited 1 reply Add to Favorites Watch
View snidd111's profile

snidd111

5 posts in 61 days


11-01-2017 10:10 AM

Topic tags/keywords: powermatic question

Hey guys,

i was finally able to find the adjustable jaw for the upper jaw assembly by using a Delta 40-440 and grinding it down a little to fit properly. But, once I got a blade mounted, it appears that the blade guide is somehow way off its alignment? Or somehow the rod holding the upper end of the blade is off? I’m not sure how that’s possible with the way it’s designed though. Any help would be awesome!

Also, Can someone confirm that this lower jaw assembly looks correct? It won’t hold a blade dead center and that seems odd to me. (This is my first old scroll saw, so it may just be part of the curve).


1 reply so far

View snidd111's profile

snidd111

5 posts in 61 days


#1 posted 11-01-2017 12:32 PM

I was able to get the top aligned after discovering that a previous owner had reinstalled the block below the guide bearing backwards. With some finagling, I got the blade moving pretty square to the table and humming away.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com