LumberJocks

DW 735 Dust Collection

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by sharpus posted 01-23-2011 08:01 PM 1257 views 0 times favorited 6 replies Add to Favorites Watch
View sharpus's profile

sharpus

7 posts in 2409 days


01-23-2011 08:01 PM

Topic tags/keywords: planer dust collection dw735

Recently purchased a DW735 from Tool King. Factory Refurb w/ all of the existing manufacturers waranty. Works great and at $425.00 out the door I couldn’t pass it up. Wondering if anyone has any issues w/ the dust collection. I currently run a 4” hose from my DC (2 hp Reliant) straight to the machine, and absolutely NO chips are being removed. They all blow out the front. When the machine is off I can hear the DC moving air thru the machine, but still no chips. Has anyone had this problem. My thought is maybe a pathway is clogged but I don’t want to tear into the machine without a plan. Any help is appreciated.

Rick


6 replies so far

View Howie's profile

Howie

2656 posts in 2384 days


#1 posted 01-23-2011 08:39 PM

I have a 735 and my 2 hp d/c gets about 99% of the dust/chips. I’d pull the top off the machine and check for blockage and also check your hose to the d/c to see if it’s blocked and cutting down on suction.
Did it work when you first started or is this something that just developed after using it?

-- Life is good.

View mfike's profile

mfike

100 posts in 3127 days


#2 posted 01-23-2011 09:02 PM

Yeah sounds like something is blocked somewhere. Have you tried it without the dc connected? If there is no air coming out of the hood port, then you will know for sure something is clogged or the fan is not pushing air out of the planer.

View ajosephg's profile

ajosephg

1878 posts in 3022 days


#3 posted 01-23-2011 09:46 PM

Yep somethings wrong. The 735 has an internal fan that blows the chips out like crazy.

I can’t remember if Dewalt had any shipping stuff inside that area or not. If the did, and if you didn’t remove it then——-

-- Joe

View Scott's profile

Scott

150 posts in 2433 days


#4 posted 01-23-2011 10:01 PM

Agree with the others. I had the same thing happen and there was a sizable chip blocking the internal blower. It’s quick and easy to pop the top off with the supplied Allen wrench, plus it will give you a chance to get familiar with your new planer. Normally, it should be shooting all the chips out the back. I once had my DC hose fall off and it shot chips over 8 feet and they were bouncing off the wall.

View sharpus's profile

sharpus

7 posts in 2409 days


#5 posted 01-25-2011 09:40 PM

Problem solved, chips blocking the internal port, but only partially allowing enough air to get thru making me think it wasn’t blocked. Working great now, thanks for all the help

View Scott's profile

Scott

150 posts in 2433 days


#6 posted 01-26-2011 12:14 AM

Glad to hear you solved the issue!

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com