LumberJocks

Table Saw Switch Issue

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by mathom7 posted 12-04-2010 05:28 AM 705 views 0 times favorited 2 replies Add to Favorites Watch
View mathom7's profile

mathom7

69 posts in 2372 days


12-04-2010 05:28 AM

I noticed the switch on my R4511 started acting up the other day. After I switch it on, nothing, if I play with the yellow lockout buttion a little, wiggle it, and it will kick on. However, it doesn’t have the normal slow start.

I’ve tried inserting the lock button both directions same result. It doesn’t appear to be damaged,

Anybody else seen this? Any suggestions?


2 replies so far

View NBeener's profile

NBeener

4808 posts in 2635 days


#1 posted 12-04-2010 05:36 AM

My first thought would be to blow the switch out pretty thoroughly, with compressed air, and/or use some contact cleaner.

-- -- Neil

View lilredweldingrod's profile

lilredweldingrod

2495 posts in 2568 days


#2 posted 12-04-2010 10:14 AM

Open it up and check for a loose connection

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com