LumberJocks

Hitachi M12V2 question

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by KYSean posted 11-07-2010 04:13 AM 890 views 0 times favorited 2 replies Add to Favorites Watch
View KYSean's profile

KYSean

106 posts in 3057 days


11-07-2010 04:13 AM

Hi all, for anyone who owns one of these routers, the large knob with the two o rings at the bottom that connects to the fine adjustment knob, do you just press that in hard into the top of the fine adjustment knob? Also, the threaded column below the fine adjustment that fits into the base, the bottom part of the thread on mine where it inserts into the base looks like it was grabbed with a pair of pliers and the thread seems crushed on opposite sides, this is not normal is it? I got this router from amazon last year during one of their great sales but haven’t gone to used it until today. Your help with these questions would be greatly appreciated. Sean

-- http://editedwrite.com


2 replies so far

View lilredweldingrod's profile

lilredweldingrod

2495 posts in 2567 days


#1 posted 11-07-2010 07:43 AM

Sean, I have that router, and yes you have to give the knob a good push down to seat it. As for the other, there should NOT be plier or vice grip marks any where on the threaded shaft.
I got mine from Amazon last year as well and use it more than all the rest of my routers. Love this big brute.
If a picture of any other help is needed, PM me. Rand

View KYSean's profile

KYSean

106 posts in 3057 days


#2 posted 11-07-2010 04:10 PM

Thanks Rand, looks like I’ll need to order a new threaded column. Sean

-- http://editedwrite.com

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com