LumberJocks

Grizzly G0691 Table saw

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Tjboutin posted 01-01-2017 04:38 PM 349 views 0 times favorited 3 replies Add to Favorites Watch
View Tjboutin's profile

Tjboutin

1 post in 754 days


01-01-2017 04:38 PM

Hello! Hoping I can get some help here.

Setting up my new table saw and am in process of dialing in blade to miter slot to make sure all is parallel.
From reading the manual and seeing a few videos on YouTube of how I should measure from miter slot to 1 single carbide tooth and mark that tooth. Then rotate the blade to opposite end and measure to that same tooth. Well my blade does not spin, it’s hard to rotate by hand, if I push/pull the blade however far and let go it snaps back to original posistion.

Anyone know why? Seems like from what I gather the blade should spin freely by hand.

Trevor


3 replies so far

View WhyMe's profile

WhyMe

909 posts in 1394 days


#1 posted 01-01-2017 04:41 PM

Have you removed all the packing material?

View EugdOT's profile

EugdOT

208 posts in 388 days


#2 posted 01-01-2017 04:49 PM

I don’t own the saw but am familiar with the type, There is something impending the arbor or blade from spinning, you might have to take off a dust access panel to get a good look at what going on , but it’s should spin freely

View MrUnix's profile

MrUnix

5975 posts in 2032 days


#3 posted 01-01-2017 04:57 PM

Naw… that’s typical, particularly on a machine with multiple belts. Try spinning the blade by pulling on the belts or turning the motor pulley.

Cheers,
Brad

-- Brad in FL - In Dog I trust... everything else is questionable

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com