LumberJocks

Penn State Variable Speed Lathe motor running intermittantly

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by jwisbey posted 12-26-2016 06:16 PM 978 views 0 times favorited 6 replies Add to Favorites Watch
View jwisbey's profile

jwisbey

35 posts in 2251 days


12-26-2016 06:16 PM

Topic tags/keywords: question lathe

Hi all, I am hoping for some help here. I have an Excelsior lathe from Rockler that I upgraded with a varible speed motor from Penn State (1/2 hp). It is just over 1 year old and has worked great until recently. Now the motor intermittantly runs, then hesitates, then kicks on again. It does not fully stop spinning but just kicks off, kicks on randomly. This occurs at all speeds and when it is just turned on as well as when it has been running for a while. I am not sure what is occurring or how to correct. Does anyone know if I need to replace a component or do I need to get a new motor? Any help is greatly appreciated.


6 replies so far

View Mark Shymanski's profile

Mark Shymanski

5621 posts in 3551 days


#1 posted 01-10-2017 12:16 AM

Check if any switches are clean and not clogged with dust or chips. Are you working directly from a wall plug or going through an extension cord?

-- "Checking for square? What madness is this! The cabinet is square because I will it to be so!" Jeremy Greiner LJ Topic#20953 2011 Feb 2

View MrUnix's profile

MrUnix

6006 posts in 2037 days


#2 posted 01-10-2017 12:21 AM

Sounds like a loose/broken wire or connection. Open things up and remove/re-install any connectors you might find and look for broken wires. I don’t think it would have brushes, but if it does, might want to examine them as well.

Cheers,
Brad

-- Brad in FL - In Dog I trust... everything else is questionable

View jwisbey's profile

jwisbey

35 posts in 2251 days


#3 posted 01-10-2017 02:53 PM

I have been working with Penn State on this. They have already sent out a new variable speed controller, but that did not correct the issue. They are sending out new brushes now. They have been very helpful and I am glad to have that customer service.

Thanks for the suggestions.

View Notw's profile

Notw

597 posts in 1591 days


#4 posted 01-10-2017 03:28 PM

stupid question but is the plug from the motor to the control box plugged in tight? My turncrafter did this once after i moved it and it turned out to just be the connection was slightly loose.

View jwisbey's profile

jwisbey

35 posts in 2251 days


#5 posted 01-10-2017 03:39 PM

I did check that with both the old controller and the new one.

Mark Shymanski – I am plugging it directly into the wall outlet. I even tried a different plug just in case the outlet was not getting consistent current.

View jwisbey's profile

jwisbey

35 posts in 2251 days


#6 posted 01-11-2017 11:12 PM

All,

Just replaced the brushes and this corrected the issue. The old ones were in pretty good shape, so I cannot say definitively that was the issue. One of the screws holding one of the brushes in place was a little loose so that may have been it as well. Either way, it is working now and Penn State was very responsive. Thanks for the feedback.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com