LumberJocks

Delta 8" VS Ginder

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Jimbo4 posted 11-16-2016 01:28 AM 411 views 0 times favorited 4 replies Add to Favorites Watch
View Jimbo4's profile

Jimbo4

1577 posts in 2596 days


11-16-2016 01:28 AM

I have a dreaded Delta product – an 8” VS speed grinder that keeps blowing fuses, Any ideas why?

-- When I was a kid I wanted to be older . . . . . this CRAP is not what I expected !


4 replies so far

View mrbob's profile

mrbob

182 posts in 402 days


#1 posted 11-16-2016 01:38 AM

Ya you got a short some place, check the cord, the plug, ect. Maybe the outlet is bad, try it in an other one.

View Jimbo4's profile

Jimbo4

1577 posts in 2596 days


#2 posted 11-16-2016 05:02 PM

Kinda figured a short somewhere. I’m sorting thru everything – my tester says the outlet is ok. Strange that the GFCI didn’t trip.

-- When I was a kid I wanted to be older . . . . . this CRAP is not what I expected !

View Jimbo4's profile

Jimbo4

1577 posts in 2596 days


#3 posted 11-18-2016 12:21 AM

Hah! Found the problem. Replaced the plug with a new one, and grinder operates just fine. “Disassembled” the moulded rubber plug – made in China – and found the short. Typical :o(

-- When I was a kid I wanted to be older . . . . . this CRAP is not what I expected !

View Jimbo4's profile

Jimbo4

1577 posts in 2596 days


#4 posted 11-19-2016 02:01 AM

Also went online to Delta – they do not support this grinder, no parts available. This thing is only one year old – I’ll buy HF before I buy another Delta !

-- When I was a kid I wanted to be older . . . . . this CRAP is not what I expected !

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com