LumberJocks

Problem with Grizzly dust collector

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Steven H posted 07-13-2010 12:12 AM 837 views 0 times favorited 3 replies Add to Favorites Watch
View Steven H's profile

Steven H

1117 posts in 2527 days


07-13-2010 12:12 AM

I have the G0583Z 1HP Canister Dust Collector

Im having problem installing the lower bag the quick release clamp.

It’s impossible for the black spring to hook. The top clamp works fine.

Is both of the top and bottom clamps suppose to be different sizes?


3 replies so far

View Steven H's profile

Steven H

1117 posts in 2527 days


#1 posted 07-13-2010 01:38 AM

I remove the foam strip and it solves the problem.
But the manual says to install the foam stip and bag and quick relase on top of them.
I assume the manufacture packaged the wrong clamps?

View Howie's profile

Howie

2656 posts in 2390 days


#2 posted 07-14-2010 02:47 AM

call grizzley,i’ll bet they send you another clamp free of charge.

-- Life is good.

View Steven H's profile

Steven H

1117 posts in 2527 days


#3 posted 07-14-2010 04:06 AM

I have sent an email to grizzly, they will send me another clamp.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com