Problem with my sander

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by rcsh posted 06-16-2010 10:27 PM 764 views 0 times favorited 2 replies Add to Favorites Watch
View rcsh's profile


4 posts in 2341 days

06-16-2010 10:27 PM

Hi, I recently bought a Hitachi SV13YA 5” Random Orbit Finishing Sander. Everything worked great for the first two days. Now the sander shuts off randomly when I’m sanding and after about half and hour it comes back on again. This cycle of switching on and off repeats randomly and today it shut off more than 3 times. Any idea why this is happening?

2 replies so far

View Kent Shepherd's profile

Kent Shepherd

2715 posts in 2709 days

#1 posted 06-17-2010 12:20 AM

If it was a new sander, I would take it back. It should not be doing that.

I really don’t know why it is doing that. I’ve never had a sander that did.


View brunob's profile


2277 posts in 3593 days

#2 posted 06-17-2010 12:27 AM

In some sanders there is an internal electronic mechanism that shuts them down if they get too hot from overwork. That circuit may be defective or you may be pushing too hard. I’d try to lighten up the pressure a bit and see if that helps. If not, return it.

-- Bruce from Central New, if you'll pardon me, I have some sawdust to make.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics