router difficult to move in base

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by leftcoaster posted 05-22-2016 11:25 AM 492 views 0 times favorited 2 replies Add to Favorites Watch
View leftcoaster's profile


75 posts in 294 days

05-22-2016 11:25 AM

I have a Bosch 1617 and the Bosch bench top table. I undo the clamp and align the arrows to get the router into the base, twist and slide. It is VERY difficult to get it seated and yes, I am pressing the gross adjustment when I move it. It does move, but it’s a lot of work.

I don’t see any obvious obstructions. Should I use furniture wax? Is there an adjustment that would give me more play?

I also don’t see a lot of movement on bit height when I use the fine adjustment (also with the lever depressed and the clamp disengaged). So, something is not right but I am stumped as to what.

2 replies so far

View conifur's profile


955 posts in 569 days

#1 posted 05-22-2016 12:18 PM

Try waxing it and/or loosen up the nut on the clamping bracket.

-- Knowledge and experience equals Wisdom, Michael Frankowski

View Lifesaver2000's profile


541 posts in 2530 days

#2 posted 05-22-2016 02:19 PM

I had the same thing happen with this router, and a cleaning and rubbing it with paraffin fixed it right up.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics