LumberJocks

PCB270TS Blade Issues

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Dwp3 posted 03-21-2016 12:02 PM 351 views 0 times favorited 4 replies Add to Favorites Watch
View Dwp3's profile

Dwp3

3 posts in 259 days


03-21-2016 12:02 PM

Topic tags/keywords: tablesaw

While changing the blade on my saw I did something. I’ve got a nice new and very sharp 60 T blade but the arbor won’t turn. I notice that the motor level locked won’t unengaged. Any thoughts of how I might get back into the wood cutting business?


4 replies so far

View knotscott's profile

knotscott

7210 posts in 2837 days


#1 posted 03-21-2016 12:30 PM

Try taking the blade off and tapping lightly to see if you can get the blade lock to disengage. Some lube or penetrating oil might help too. You may even need to disassemble it, but it sounds like you’re stuck until it’s freed up.

-- Happiness is like wetting your pants...everyone can see it, but only you can feel the warmth....

View Dwp3's profile

Dwp3

3 posts in 259 days


#2 posted 03-21-2016 10:57 PM

Stuck I am. Thanks for the thought

View knotscott's profile

knotscott

7210 posts in 2837 days


#3 posted 03-21-2016 11:03 PM

Have you tried contacting their tech support?

-- Happiness is like wetting your pants...everyone can see it, but only you can feel the warmth....

View Dwp3's profile

Dwp3

3 posts in 259 days


#4 posted 03-21-2016 11:13 PM

The problem occurred late Saturday night. Called Tech Support this afternoon but they were closed. Will attempt to call tomorrow

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com