Trouble with my new Wynn filter...need some answers!!!!!!!!!!!!!!

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Rick Dennington posted 02-26-2010 05:03 AM 1304 views 0 times favorited 2 replies Add to Favorites Watch
View Rick  Dennington's profile

Rick Dennington

5103 posts in 2614 days

02-26-2010 05:03 AM

Greetings guys and dolls: My new filter came in Wednsday night. So Thrusday morning I got up early to get started emptying and cleaning the d.c. and other things to do. So, after a 1/2 pot of coffee and a few smokes, I headed to the shop. Well I got the aformentioned done, and removed the filter from the box, along with the free bags, turnbuckles, and instructions. When I saw this thing I thought” this sucker’s too small”. My d.c. is a Delta 50-850, and the filter is a smaller diameter than the diameter of the collector…
hhuumm…somethings not right here, I don’t think. But I put it on, and there was about 1 1/2” of space between the filter and the rim of the d.c. all the way around. But then I tried the turnbuckles, and “crap”... they don’t work….too long!! They won’t hook on to the rim of the filter and rim of the d.c. Sooo… I call and talk to Mr. Wynn, and we go through the procedure of solving the problem. After I did what he said, “crap”,
still won’t work. The only solution was to use 4 small clamps to try to fix this to get the rubber gasket to seat down….. well…that’ll work, I think. So I got the bag put on, everything adjusted, turned it on….ooohhh, that sounds good. Checked several blast gates for suction…nice!!!! So I got started milling up some timber for some cabinets I’m building. A couple of hours later it was time for a coffee and smoke break, and rest my ole’ aching back!!! I better check things. I looked and there was dust all around the inside around the bottom of the filter and dust all over the collector…fine dust… what a pi….r. Took the bag off, checked the clamps… nope..still tight. Where is it coming from? Vacumned it good, and quit for the night. Today…. same thing all over again…..So… I’ll call Mr. Wynn in the morning ..again. But now the big question for you guys that have this filter is this: How do I fix this problem just short of returning the thing? Oh..I almost forgot, this is the 35A NANO. If you guys out there that owns this thing could tell me, I’d be indebted to you just short of giving up life and limb…...... I await the results with patience and vigor…....Thanks a bunch…..

-- At my age, an "all--nighter" is not having to get up and pee...!!!

2 replies so far

View Mark Shymanski's profile

Mark Shymanski

5300 posts in 3132 days

#1 posted 05-19-2014 06:06 PM

At 1543 days old I suspect that your ‘patience and vigor’ waiting for an answer have wained somewhat LOL! Did you ever resolve this?

-- "Checking for square? What madness is this! The cabinet is square because I will it to be so!" Jeremy Greiner LJ Topic#20953 2011 Feb 2

View Wildwood's profile


1850 posts in 1554 days

#2 posted 05-19-2014 09:07 PM

If scroll down page will see how to make modifications to make your canister work.

-- Bill

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics