LumberJocks

Titebond 3 drying black

  • Advertise with us

« back to Finishing forum

Forum topic by DirtyMike posted 03-01-2016 03:47 AM 335 views 0 times favorited 1 reply Add to Favorites Watch
View DirtyMike's profile

DirtyMike

454 posts in 365 days


03-01-2016 03:47 AM

I know this has been discussed many times so please be patient. Tonight while cleaning up in my shop i was moving my bessey f style clamps. I noticed that all of the glue on the chrome bar dried to black. I have had some of the same glue dry black on a cutting board i did before Christmas out of the same bottle. I wouldn’t think that white glue would dry black on a plated metal like that.. sorry forgot to take pics. Did i get a bad batch of glue ?


1 reply so far

View ShapingGrain's profile

ShapingGrain

14 posts in 277 days


#1 posted 03-04-2016 12:49 AM

It seems like it is reacting to the steel bar. I have this problem with pipe clamps. To prevent it is do two things:

1. I take more time to ensure noo metal is touching glue spots.
2. I separate with wax paper

To test if you have bad glue simply squirt some on a white piece of paper and let it dry

-- Ken, New Hampshire, www.shapinggrain.com

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com