LumberJocks

Dust Collector Problem

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Joseph Crivelli posted 12-22-2009 09:31 PM 862 views 0 times favorited 4 replies Add to Favorites Watch
View Joseph Crivelli's profile

Joseph Crivelli

44 posts in 2718 days


12-22-2009 09:31 PM

Last week I received the Mini Dust Collection Separator (#143868) from Woodcraft.

My Shop-Vac is a 1993 model and the 2 1/2” hose will not slip onto the inlet or outlet. The hoses and the fports are exactly the same size.

To rectify the problem, I used two 3” cans (cut along the length) and 4 pipe clamps to make two unions. The idea works fine and I am delighted with the Separator.

-- SOLTC


4 replies so far

View GaryK's profile

GaryK

10262 posts in 3455 days


#1 posted 12-22-2009 09:33 PM

So what’s the problem? :-)

You gotta do what you gotta do.

-- Gary - Never pass up the opportunity to make a mistake look like you planned it that way - Tyler, TX

View Joseph Crivelli's profile

Joseph Crivelli

44 posts in 2718 days


#2 posted 12-22-2009 09:36 PM

Just thought I’d pass this along.

Woodcraft appreciated the solution.

-- SOLTC

View hairy's profile (online now)

hairy

2384 posts in 2999 days


#3 posted 12-22-2009 10:34 PM

What? No duct tape?

-- stay thirsty my friends...

View Joseph Crivelli's profile

Joseph Crivelli

44 posts in 2718 days


#4 posted 12-22-2009 10:35 PM

No, don’t need it!

-- SOLTC

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com