LumberJocks

Planer Feed

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Beeguy posted 10-14-2009 06:34 PM 1718 views 0 times favorited 13 replies Add to Favorites Watch
View Beeguy's profile

Beeguy

178 posts in 3103 days


10-14-2009 06:34 PM

Hi,

I have a Ridgid 13” planer. I have been having a problem with the feed control. After I run a few boards through they will get stuck and it looks like the roller is turning because it leaves a mark but the board stops feeding. The blades are sharp and make a clean cut. The table is clean and smooth and has polish. A loose board will glide over it like ice. I never take off much material with single pass.

The only thing I can come with is the roller is getting “slippery”. I got the idea because the rollers on an inkjet printer will do the same over time. I wiped them down with alcohol and it seems to work for awhile but it will start up again sooner or later. It is a pain to wipe the roller because you can’t manually advance it unless you take everything apart. So I can only clean a small section at a time turning it on and off.

Am I doing something wrong, or is this a common problem? Is there a fix?

Thanks!

-- Ron, Kutztown, PA "The reward is in the journey."


13 replies so far

View Chris Wright's profile

Chris Wright

540 posts in 2948 days


#1 posted 10-14-2009 06:53 PM

It could be that the roller is worn out. See if it’s possible to replace or even upgrade it. Just a thought.

-- "At its best, life is completely unpredictable." - Christopher Walken

View webwood's profile

webwood

626 posts in 2717 days


#2 posted 10-14-2009 07:04 PM

i blow mine down after every pass as the dust builds up on the rollers

-- -erik & christy-

View Dan Lyke's profile

Dan Lyke

1510 posts in 3592 days


#3 posted 10-14-2009 09:50 PM

I’ve been trying to take really thin cuts off my boards with my planer (a DeWalt 735), and have had similar problems. I think it does a lot better if I take a good solid layer off rather than just trying to kiss the face of the boards with the blades.

-- Dan Lyke, Petaluma California, http://www.flutterby.net/User:DanLyke

View Dale's profile

Dale

11 posts in 2617 days


#4 posted 10-15-2009 02:59 AM

I’ve had the same problem with my DeWalt 734. I’ve cleaned the rollers which doesn’t seem to make much difference. A good table waxing before use seems to be the best solution I’ve found.

-- -Dale

View matt garcia's profile

matt garcia

1877 posts in 3139 days


#5 posted 10-15-2009 03:22 AM

I had that same experience on my 13” Delta. I read a post indicating to clean the rollers with alcohol, and then wax the table. I’ve been doing that ever since, no problems!

-- Matt Garcia Wannabe Period Furniture Maker, Houston TX

View spindle's profile

spindle

11 posts in 2640 days


#6 posted 10-15-2009 03:35 PM

Alcohol can harden rubber rollers over time. I use some stuff called Rubber Renue, http://www.gatewaycatalog.com/cgi-bin/category.cgi?item=2400-00083&type=store. You can go a lot longer between cleanings than with alcohol as well. This size bottle will last for years. Just be sure to have some ventilation. The stuff will make you light headed. I wipe what ever part of the roller is exsposed, toggle the power switch and wipe the next bit. It’s kind of hassle pulling the power cord lose ever time, but it’s quicker than tearing everthing down. Like Matt and Dale said waxing the tables really helps.
I also had to replace the springs that put tension on the infeed roller on my Ridgid. They only cost a couple of bucks and take 30 or 45 min. to replace. Ridgid CS can give you the number of a place in Ohio that sells replacement parts.
Greg

View patron's profile

patron

13538 posts in 2808 days


#7 posted 10-15-2009 03:42 PM

maybe the outfeed roller is to loose ?

-- david - only thru kindness can this world be whole . If we don't succeed we run the risk of failure. Dan Quayle

View CharlieM1958's profile

CharlieM1958

16244 posts in 3685 days


#8 posted 10-15-2009 04:14 PM

I just got the Ridgid planer and was putting it through its paces for the first time yesterday. I had the same thing happen on one particular board, even though it didn’t look any different from the others I was working with.

The first time it failed to feed. I shut down the planer and removed the board. When I tried again and the same thing happened, I gave it just a slight push and it fed right through.

-- Charlie M. "Woodworking - patience = firewood"

View SnowyRiver's profile

SnowyRiver

51452 posts in 2947 days


#9 posted 10-15-2009 05:55 PM

I have a Dewalt planer and had this same problem. I was doing reclaimed American chestnut. After a few boards, the planer wouldnt pull the board through. I couldnt figure out what was going on. I think it was from the old wood and it had a dark sticky surface. I decided to wax the planer table…that fixed it…worked fine. You might try that.

-- Wayne - Plymouth MN

View Beeguy's profile

Beeguy

178 posts in 3103 days


#10 posted 10-15-2009 07:53 PM

Thanks for all the comments. I have not used the planer all that much so nothing is really worn. I do keep the table waxed so it may be a combination of dirt on the roller and my not taking off to much at a time. I will try some of the suggestions and see what happens. If I am able to identify one specific cause and cure I will report back because it sounds like this is common with planers.

-- Ron, Kutztown, PA "The reward is in the journey."

View dbhost's profile

dbhost

5609 posts in 2699 days


#11 posted 10-15-2009 08:15 PM

Did you register your planer when you bought it? If so take advantage of the Ridgid Lifetime Service… Call them and get this straightened out…

Honestly though, it sounds like a slick / slipping roller.

-- My workshop blog can be found at http://daves-workshop.blogspot.com

View SCOTSMAN's profile

SCOTSMAN

5839 posts in 3052 days


#12 posted 10-15-2009 09:04 PM

Hey I had a dewalt planer thicknesser and the roller was worn badly easy to replace it was the fault of the guy I bought it from five minute job. Seriously check the rollers if one is worn just replace it.Alistair

-- excuse my typing as I have a form of parkinsons disease

View longgone's profile

longgone

5688 posts in 2776 days


#13 posted 10-15-2009 11:20 PM

I had a dewalt 734 that worked fine. Never had a problem until I upgraded to the Dewalt 735. Then the problem started with the rollers stalling. Brought it to Dewalt service center and after the had it for 2 weeks it worked for 1 day. What a lemon!
I finally gought a Grizzly 15” planer and it has worked flawlessly in the last year I have had it.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com