LumberJocks

customer service

  • Advertise with us
Review by hootr posted 1839 days ago 1340 views 0 times favorited 7 comments Add to Favorites Watch
customer service No-picture-s No-picture-s Click the pictures to enlarge them

i emailed freud customer service yesterday (saturday) about a problem with my router and to my surprise this morning they had responded with the information on parts and a tech support #. i really wasn’t expecting that over a weekend. great service i think

the FT2000E has been table mounted since new, the last couple years, with no complaints
the other day the router wouldn’t start. flipped the switch a couple times and it started. happened again a little later. loose wire, bad switch???? don’t know but now i’m nervous. then i notice the variable speed dial is gone.
i’m not knocking the router, it’s a great machine but has anyone else had this problem?
i’ll let you know how the repair goes when i get the parts

-- Ron, Missouri




View hootr's profile

hootr

183 posts in 1945 days



7 comments so far

View cabinetmaster's profile

cabinetmaster

10874 posts in 2157 days


#1 posted 1839 days ago

I’ve not had any problem with my Freud yet. Knock on wood. Looks like you got a quick responce though. Keep us posted on how everything comes out.

-- Jerry--A man can never have enough tools or clamps

View SnowyRiver's profile

SnowyRiver

51451 posts in 2079 days


#2 posted 1839 days ago

Always nice when they respond so quick. Maybe its something simple like a dirty switch. Good luck with it.

-- Wayne - Plymouth MN

View Derek Lyons's profile

Derek Lyons

584 posts in 2166 days


#3 posted 1839 days ago

Not much of a review here…

-- Derek, Bremerton WA --

View a1Jim's profile

a1Jim

111999 posts in 2175 days


#4 posted 1839 days ago

Hope it comes together for you

-- http://artisticwoodstudio.com Custom furniture

View Don Newton's profile

Don Newton

712 posts in 2217 days


#5 posted 1836 days ago

How can it rate 5 stars when it sounds like it is falling apart?

-- Don, Pittsburgh

View reggiek's profile

reggiek

2240 posts in 1868 days


#6 posted 1836 days ago

Glad to hear some good news about customer support these days….lots of nightmares out there lately. It does sound like some infiltration of the switch perhaps….that seems to be the focal point for problems on most routers….there has been a lot of engineering devoted to specifically that too…I make it a practise to blow out my router after each use just to insure that I dont cause the switch to fail…its easy and only takes a couple minutes.

I would certainly rate the customer support high…but just one problem like this would not make me consider the tool as inferior unless I saw a few more notices of failures…

Keep us abreast of the results.

As an aside, I have used alot of their bits and have nothing but praise for the quality and workmanship…hope they keep it up.

-- Woodworking.....My small slice of heaven!

View hootr's profile

hootr

183 posts in 1945 days


#7 posted 1833 days ago

guess i wasn’t plain enough or put this comment in the wrong place
i was just bragging on the customer service, the tool is top notch
after talking to the tech guy i took it apart, cleaned it up and it runs like a champ
better housekeeping on my part should be the answer

thanks for the feedback both pro & con

-- Ron, Missouri

Have your say...

You must be signed in to post the comments.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase