LumberJocks

Amazing improvement on my table saw

  • Advertise with us
Review by jakep_82 posted 05-02-2014 09:02 PM 3458 views 2 times favorited 20 comments Add to Favorites Watch
Amazing improvement on my table saw No-picture-s No-picture-s Click the pictures to enlarge them

I’ve already replaced the belts on most of my machines with link belts, but I never really felt like it was a huge improvement. After swapping the belts on my table saw I realize just how much difference they can make.

I have a 15 year old Grizzly G1023 which has a triple 3L belt pulley. I bought the saw for a song on Craigslist because it had a blown motor, but I had no idea how it ran. After I got the motor fixed I found out it had a significant thump at startup, as well as some noticeable vibration. My new Tenryu combo blade left noticeable saw marks on every cut. After making the swap the startup thump is completely gone, and that same blade now produces glass smooth cuts. I couldn’t be happier.

One other note about where I bought this belt. I ordered from Ozark Woodworker and they shipped the same day. I had the belt in my hands within 3 days of ordering, and the shipping was free. Excellent customer service.

If you have a cabinet saw with a little vibration I would strongly recommend trying this belt.

http://www.ozarkwoodworker.com/38x-1ft-Link-V-Belt-Type-3L-BDH-DuroDrive-Replacement-Belts_p_917.html




View jakep_82's profile

jakep_82

45 posts in 956 days



20 comments so far

View mantwi's profile

mantwi

312 posts in 547 days


#1 posted 05-03-2014 01:11 AM

Thanks for the heads up on this source. I too have an older G1023 and after new bearings and motor were installed thought I’d switch to a link belt just to see if it really made a difference. Woodcraft had 1/2” belts and they are too wide. Fortunately my saw does cut smoothly as is but being the obsessive compulsive type I really want a link belt on it. Now I can sleep again.

View Rick M.'s profile

Rick M.

3942 posts in 1031 days


#2 posted 05-03-2014 05:39 AM

Yep, they work well. My saw was fairly smooth (or so I thought) but always had a slight shudder as the blade stopped. Switched to a link belt and holy moly did it make a difference.

-- |Statistics show that 100% of people bitten by a snake were close to it.|

View HillbillyShooter's profile

HillbillyShooter

4559 posts in 943 days


#3 posted 05-03-2014 01:40 PM

Thanks for your review and the source. I have link belts on just about all my machines except the triple belts on my TS and planer. I’ll check this out.

-- John C. -- "Firearms are second only to the Constitution in importance; they are the peoples' liberty's teeth." George Washington

View ras61's profile

ras61

92 posts in 172 days


#4 posted 05-03-2014 05:59 PM

Are these Duro Drive belts better than other link belts?

-- "South Carolina is too small for a republic and too large for an insane asylum" - James L. Petigru, 1860

View patcollins's profile

patcollins

995 posts in 1516 days


#5 posted 05-03-2014 08:44 PM

Thinking that may be the same belt that Harbor Freight sales

View oldnovice's profile

oldnovice

3757 posts in 2018 days


#6 posted 05-03-2014 09:42 PM

I added that, and turned pulleys, to my Craftsman TS over 25 years ago and I still marvel at the improvement it made.

Many years ago, as part of job, I worked with the USPS to add vibration sensing and FFT software to some of the machines as vibrations, of any kind, and those that change are indications of potential problems.

Sort of goes opposite of the old song ”Good Vibrations”.

-- "I never met a board I didn't like!"

View Dusty56's profile

Dusty56

11657 posts in 2338 days


#7 posted 05-04-2014 02:18 AM

Any real life photos of your belt ?
$8 /foot with 3 foot minimum order should be mentioned in your “review”.

http://www.harborfreight.com/vibration-free-link-belt-43771.html
5’ for $25 if you need 1/2” wide belt : )
I’ve had excellent results with the Accu-Link brand from HF

-- I'm absolutely positive that I couldn't be more uncertain!

View jakep_82's profile

jakep_82

45 posts in 956 days


#8 posted 05-04-2014 02:27 AM

I have the Harbor Freight belt on my jointer and it works well. I can’t say that it made a huge improvement because it already ran pretty smooth, but it does seem to work well.

I looked around for quite a while to find the best price on 3/8” link belt and Ozark seems to be the lowest. I’m glad I ordered from them and I won’t hesitate to buy other stuff from them.

View b2rtch's profile

b2rtch

4322 posts in 1699 days


#9 posted 05-06-2014 07:52 PM

I have the HF version on all my equipment including my Unisaw (someone on LJ told me that I could not install these belts on a Unisaw)

-- Bert

View TobiasZA's profile

TobiasZA

128 posts in 189 days


#10 posted 05-06-2014 08:04 PM

I have these belts on my drill press, jointer and table saw. They have been on for about fifteen years now and are still running beautifully. If I remember correctly, I bought them from Lee Valley. They are definitely worth every cent.

Cheers
Tobias

View LJackson's profile

LJackson

155 posts in 244 days


#11 posted 05-06-2014 09:47 PM

Mostly off topic, but how did you get the motor fixed? I blew the motor on my drill press and was just looking at purchasing a new one, figuring it couldn’t be repaired. It is expensive to replace.

View jakep_82's profile

jakep_82

45 posts in 956 days


#12 posted 05-06-2014 10:20 PM

My answer probably won’t help you. I happen to have a good friend that works at an electric motor repair shop. He owed me a favor and I cashed it in on my saw. It needed a new primary winding which likely would have cost more than a new motor, but he covered the materials and the entire repair was free for me. If the motor just has a blown capacitor it’s easy and inexpensive to fix. If anything is wrong with the windings you’re better off getting scrap value for the copper and buying a new motor.

View LJackson's profile

LJackson

155 posts in 244 days


#13 posted 05-08-2014 05:05 PM

I likely overheated the motor, and it probably needs new windings. I figured that my only solution was a new motor. I didn’t hear a cap snap, nor smell the tell-tail odour.

View jakep_82's profile

jakep_82

45 posts in 956 days


#14 posted 05-08-2014 05:18 PM

I wish I had a better answer. Unfortunately rewinding motors is almost an art form, and it’s very time consuming. My friend had actually never worked on a motor as small as my puny 3HP. Most of what he works on are 20HP up to 1000+HP. On motors that big it’s much easier to justify the cost of the repair versus buying new.

View LJackson's profile

LJackson

155 posts in 244 days


#15 posted 05-08-2014 06:40 PM

No worries. I’m glad for the information you’ve provided. It’s a learning experience, as I’ve never burnt a motor before. When it happened, I knew pretty quickly what I’d done, and just a little research confirmed my suspicion.

Now I’m looking to get a 1HP motor to replace the 1/2HP one I killed. I figure that would reduce my chance of killing it again. Do you have any hints on where to find such a motor? It seems to be hard to find a motor of that power that runs on 110VAC and a standard 15 or 20 amp circuit. Also, it needs to be…1725 rpm I think. It would be a big bonus if the shaft diameter was identical to the one that I’ve currently got, but I’m not going to go so far. I can probably obtain an adapter.

showing 1 through 15 of 20 comments

Have your say...

You must be signed in to post the comments.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase