LumberJocks

All Replies on Grizzly Table Saw Starting issues

  • Advertise with us
View seturner's profile

Grizzly Table Saw Starting issues

by seturner
posted 09-14-2017 04:10 AM


11 replies so far

View AZWoody's profile

AZWoody

1404 posts in 1373 days


#1 posted 09-14-2017 04:26 AM

Have you checked the start capacitor?

When I had issues with my Grizzly table saw, I had to check it and that was the problem.
They told me to put an ohmeter on it and if the numbers slowly increased, then it’s working.
If the numbers jump around all over the place, it’s gone bad.

View xmastree's profile

xmastree

47 posts in 1129 days


#2 posted 09-14-2017 04:43 AM

In my experience, when a start capacitor fails the motor will only hum when current is applied, and will run if the motor is spun manually with power on (can’t imagine there’s a safe way to test that on a table saw).
You say the motor will sometimes “stop running when you let go” of the button. Since this model comes with a magnetic switch I believe that is the part that is intermittently failing.

-- Every tree is a Chistmas tree with its gifts hidden inside.

View TheFridge's profile

TheFridge

10360 posts in 1635 days


#3 posted 09-14-2017 04:53 AM

The seal in or auxiliary contact isn’t making contact. It’s the NO/NC set of contacts that the wires after the start and in between the start/stop go to.

-- Shooting down the walls of heartache. Bang bang. I am. The warrior.

View MrUnix's profile (online now)

MrUnix

6949 posts in 2348 days


#4 posted 09-14-2017 04:53 AM

Certainly wouldn’t have anything to do with the capacitor… problem lies in your magnetic switch. Could be any number of things, but it sounds like a loose connection somewhere. Could also be faulty/dirty contacts in the switch or relay contacts, or even a failing coil. Gonna need to do a little more digging than just looking for dust :)

Cheers,
Brad

-- Brad in FL - In Dog I trust... everything else is questionable

View mrg's profile

mrg

828 posts in 3148 days


#5 posted 09-14-2017 10:17 AM

Your key words was its a new Grizzly table saw. I would be on the phone with them if it’s still under warranty. Your symptoms sound like a bad switch.

-- mrg

View mrg's profile

mrg

828 posts in 3148 days


#6 posted 09-14-2017 11:28 AM



Your key words was its a new Grizzly table saw. I would be on the phone with them if it s still under warranty. Your symptoms sound like a bad switch.

- mrg


My bad I misread the new to me. The symptoms sound like a bad mag switch als check all your wire I get connections to make sure they are tight, a split second of no contact or low power will make the switch disengage.

-- mrg

View TheFridge's profile

TheFridge

10360 posts in 1635 days


#7 posted 09-14-2017 04:05 PM

Yeah it could definitely be a loose wire as well coming from in between the start and stop. Trace it out. If it’s well connected then it’s something to do with the contact it goes too.

If the coil was going bad it would tend to chatter.

-- Shooting down the walls of heartache. Bang bang. I am. The warrior.

View finns's profile

finns

167 posts in 3265 days


#8 posted 09-15-2017 05:25 PM

Hey Scott. I’ve had this happen several times on two different Grizzly machines. In all cases, the starting capacitor shorted out. The resolution was to replace the capacitor and the cebtrifugal switch at the same time. I first called Grizzly tech support who walked me through troubleshooting. They also have a video on their website on how to replace the components.

I now keep a set of these components on hand as I can’t afford the down time.

View seturner's profile

seturner

29 posts in 568 days


#9 posted 09-21-2017 03:04 AM

See original post for update please.

View MrUnix's profile (online now)

MrUnix

6949 posts in 2348 days


#10 posted 09-21-2017 03:10 AM

Google is your friend... I’m sure you can find one out of all those results. Looks like about a $10 (+shipping) repair.

Cheers,
Brad

-- Brad in FL - In Dog I trust... everything else is questionable

View TheFridge's profile

TheFridge

10360 posts in 1635 days


#11 posted 09-21-2017 03:37 AM

First time for everything.

-- Shooting down the walls of heartache. Bang bang. I am. The warrior.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com