Free Kreg Jig Giveaway

  • Advertise with us
Blog entry by JSB posted 02-01-2014 03:19 AM 1006 reads 0 times favorited 8 comments Add to Favorites Watch

Hello LumberJocks. I just wanted to share a giveaway that I’m having in February. I have been fortunate enough to have room in this month’s budget to allow me to give back to all of those who have showed their support for me. In February I am giving away a new Kreg Jig K4. If you would like all the info here is the link.

-- Jay -

8 comments so far

View sweetsaw's profile


32 posts in 1093 days

#1 posted 02-01-2014 02:10 PM

I use my kreg jig a lot, it is 20 years old and I would like a new one.

-- Doyle, OHIO

View Armandhammer's profile


235 posts in 662 days

#2 posted 02-02-2014 07:16 AM

Your site is broken and won’t let me enter…

View JSB's profile


731 posts in 1114 days

#3 posted 02-02-2014 08:41 AM

Armandhammer – Not sure what you mean…everything is working fine on my end…

-- Jay -

View Brett's profile


919 posts in 1795 days

#4 posted 02-05-2014 03:26 PM

Jay, no website available here either. Link or typed in. Just FYI

-- Hand Crafted by Brett Peterson John 3:16

View JSB's profile


731 posts in 1114 days

#5 posted 02-05-2014 03:28 PM

Not sure what’s going on. I’m working on a post right now and everything is working just fine. Just checked on another laptop with wifi and its working.

-- Jay -

View RCHarvey's profile


13 posts in 630 days

#6 posted 02-06-2014 09:47 PM

“Error Establishing a Database Connection”

-- - many trees died so that I may create the perfect breadboard. Someday. Probably not soon.

View PurpLev's profile


8520 posts in 2684 days

#7 posted 02-06-2014 09:58 PM

you might want to “test” it from a computer using a different network connection. look like you have some access issues when your database is accessed from the net (maybe you are testing it locally so not running into same issues).

-- ㊍ When in doubt - There is no doubt - Go the safer route.

View JSB's profile


731 posts in 1114 days

#8 posted 02-06-2014 10:05 PM

Sorry guys. I had a massive spike in traffic right when my cache plugin decided to quit working. Should be working now depending on if your ISP caches sites.

-- Jay -

Have your say...

You must be signed in to post the comments.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics