LumberJocks

$100 CL grab WIP

  • Advertise with us
Blog entry by DrewT posted 04-16-2013 04:00 AM 840 reads 0 times favorited 2 comments Add to Favorites Watch

This thing is covered in glue and rust but I am making progress – what a mess!!

Motor is going to repair shop – I don’t do electrical. Hoping its the start capacitor…all the other tools that came with this 100.00 purchase work fine but the bandsaw are not user friendly at all.



2 comments so far

View Rick M.'s profile

Rick M.

3942 posts in 1031 days


#1 posted 04-17-2013 04:20 AM

I see orange so I’m guessing it’s a Rigid? There is so little info in your post I’m trying to fill in the blanks. I’m guessing you bought a Rigid TS with a bad motor, some kind of bandsaw you don’t like, and some other mystery tools for $100 off CL?

-- |Statistics show that 100% of people bitten by a snake were close to it.|

View DrewT's profile

DrewT

32 posts in 560 days


#2 posted 04-17-2013 02:09 PM

Sorry – 2 bandsaws a scroll saw and a TS3650. motor is buzzing but doesnt kick on so im hoping its the start capacitor. The 100- i paid was all for the saw but he threw in the other tools which are all Craftsman and they work but the bandsaws need tires and blades.

Have your say...

You must be signed in to post the comments.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com

Latest Projects | Latest Blog Entries | Latest Forum Topics

GardenTenders.com :: gardening showcase